I won’t bore you further

I’m not going to continue to prattle on constantly about my failures and hopefully some successes with SharePoint 2010, but I do want to take an opportunity to illustrate the fact that the testing, like you have seen over the past few posts, all ends up in my Windows SharePoint Operations Guide.

This means, that if you are a subscriber, you are going to save plenty of time by not having to determine how to get everything working. That is my job. I do all the hard yards testing and retesting all the options. Everything that I learn about SharePoint ends up in the Guide not just SharePoint 2010 but also Windows SharePoint Services v3 (WSS), Microsoft Office SharePoint Server (MOSS) and Business Productivity Online Suite (BPOS). It’s all there, with more being added every month.

I’m happy to announce that from December the complete Guide DVD will be available for download every month. Be warned, that means > 4.3GB of information through your Internet connection. It is also starting to look like I’ll have to expand the Guide onto a second DVD starting in the New Year. I’d challenge you to find a more comprehensive SharePoint resource (perhaps apart from Microsoft themselves) for the price. So if you are a subscriber watch out for the December update which will start to include information on SharePoint 2010.

Also, don’t forget our regular webinars. The next will be:

091126The basics of using SharePoint
Topics covered:

– How to upload and management documents.
– How to create and manage wikis
– How to work with lists.
– How to create sub sites


Presenter:              Robert Crane
Date:                      Thursday 26th of November 2009
Time :                    10.00am (Sydney, Australia time)
Duration:               30 minutes
Cost:                      Free
Level:                     1 (Basic)
Prerequisites:         None

Details
This webinar will show you the basics of using a SharePoint. It will help you understand the benefits of using SharePoint to store documents and other information. You’ll also learn the basics of extending a SharePoint to include features such as wikis and sub sites.


Registration:      To register send an email to director@ciaops.com.

Normal programming will resume shortly.

Don’t forget Search Server Express

With all the hoopla surrounding SharePoint 2010 beta you should also not forget that there is also a new beta for Search Server Express.

 

image_2_1A44EA3A

 

Like the previous version, Search Server 2010 Express is a free download from Microsoft. As you can see from the above screenshot  I have just completed installing it and am now beginning to learn about what makes it tick.

 

I am still at a loss as to why more people don’t see the benefit of Search Server Express. It allows you to index just about all your documents on your file servers including all the information inside them without having to make any changes and search them from a web interface. This means no matter how messed up your existing file storage is, with Search Server Express you’ll be able to find what you’re after.

 

Just about everyone uses Google to find stuff they want outside their business yet they have NOTHING to achieve the same inside their business. Am I the only one that sees the opportunity here to provide a solution? Am I the only one that sees the opportunity to do this with a product that costs nothing to obtain? Clearly I must be, because no one else I have ever met has even heard of Search Server Express.

 

As I have said in this blog before, it is no longer about the information it is about finding the information you want quickly. Google has built a multi-billion business doing just that so why hasn’t it be done inside businesses? Beats me, but don’t say I didn’t tell you how it could be done.

Another failed attempt

After the last failure I created a new clean Windows SharePoint v3 site. I then added all the Microsoft templates that are present on my Internet facing site. I then restored the Internet facing site from a backup and commenced the upgrade to SharePoint Foundation 2010 beta again.

 

After installing the files the configuration wizard started and this time failed pretty quickly with this nasty error:

 

image_2_410AF749

 

An exception of type Microsoft. SharePoint.Upgrade.SPUpgradeException was thrown. Additional exception information: One or more types failed to load. Please refer to the upgrade log for more details.

 

Now this is interesting, because in my last attempt (with no additional templates) I got past this stage (even though it failed later).

 

Whatever the result I’m going to have to dig deep into the log and start trying to work out what the problem is. If you have never done this let me tell you it ain’t much fun.

A do not do list

Since I wrote the post of ‘Being busy is just an excuse’ I’ve come across some additional information that reinforces the premises I put forward.

I came across a something that said ‘achieving perfection is about elimination’ which resonates very strongly I believe. When a sculptor creates a work they don’t do it by adding something to what they started with, they generally chip away and remove stuff to create their work of art. The same is true about life in general I believe. You need to eliminate, simply, declutter and generally do less to achieve your goals.

I’ve also found a very interesting piece by Jim Collins who wrote the books Good to Great and Built to Last. At the beginning of the year he doesn’t make a traditional ‘to do’ list he makes a ‘not to do’ list. Novel eh? You’ll find the whole article on his web site but again it demonstrates the point of achieving the things you want by not doing the things that waste your time and are unproductive.

A similar idea comes from Carl Newport who says

Fixed-Schedule Productivity: How I Accomplish a Large Amount of Work in a Small Number of Work Hours

The basic idea being that you set your ideal work schedule and then MAKE everything fit into that. The above blog post from Carl is a highly recommended read for people who claim they are ‘too busy’ to achieve things as there are also plenty of other helpful tips in there.

So if you are too busy you have no one to blame but yourself. The good news is that you can makes the changes requires to actually achieve so much more by actually doing less. The proof is in the pudding as these articles demonstrate. I’d urge you to at least give it a try and whether you can make it work for you.

SharePoint 2010 beta in place migration

The next test on the list to conduct with SharePoint Foundation 2010 beta is an in place upgrade. In this case what I did was create a new Windows SharePoint Services v3 machine and use the STSADM command to import my existing internet facing SharePoint site http://supportweb.ciaops.net.au.

 

image_2_2DB68CB0

 

I then commenced the installation of SharePoint Foundation 2010 beta.

 

In due course it found an existing site and provided the option to upgrade as expected

 

image_4_5BA3DF68

 

At the end of the configuration it commenced the site upgrade.

 

image_6_5BA3DF68

 

Which you could view from the browser.

 

image_8_5BA3DF68

 

Unfortunately, after a while the upgrade process failed.

 

image_10_46B25CF5

 

The good thing this time was the original site was still working.

 

image_12_46B25CF5

 

Looking at the error log that was produced (with 233 errors), most seem to be about missing components (i.e. templates, add-ons etc), so I get the feeling it would have probably worked if I had done the migration on the original box where all the other add ons are installed. Problem is, that box isn’t 64 bit so a migration to a new 64 bit base machine is going to be necessary. Clearly, that is going to make any migration process that much longer and more challenging in that you have to get all the extra little ‘tweaks’, you added across onto the new machine before you attempt an upgrade. That could certainly take some time and test your memory!

 

So, it’s back the lab once again.

Flaming wreck

Buster the SharePoint 2010 beta crash test dummy is back again with some good and bad news. First, the good news is that the recent light bulb moment from last time allowed the successful install of SharePoint Foundation 2010 beta on SBS 2008.

 

image_2_3785D9EC

 

The bad news is that the upgrade process after this failed.

 

image_4_3785D9EC

 

Digging through the log file produces the following error:

 

[psconfigui] [WyukonToSqlExpress] [ERROR] [11/21/2009 7:10:00 AM]: An error occured while trying to grant the user
NT AUTHORITY\NETWORK SERVICE access to the SharePoint_AdminContent_d4e397f2-a27a-48a0-a628-d25db6672bab database
on the SQL server, CIASVR01\SharePoint.  This may be expected if the caller does not have permission to perform
this operation in sql server or if the database is read-only.  To ensure that SharePoint functions correctly,
manually grant this user access to the database before performing this operation.  The user must also be granted
access to the db_owner group in the database.  The following information was provided with this error:
System.Data.SqlClient.SqlException: Cannot open database “SharePoint_AdminContent_d4e397f2-a27a-48a0-a628-d25db6672bab”
requested by the login. The login failed.
Login failed for user ‘SBS2008\robert’

 

Which unfortunately results in http://companyweb ceasing to work.

 

image_6_3785D9EC

 

Blast. So close. Seems like an error that can be over come with a little bit of tweaking on the permissions so we’re now off to try that.

 

Message from the labs is currently still – DON’T install SharePoint Foundation 2010 beta on SBS 2008!

Light bulb moment

It’s Buster the SharePoint crash test dummy back with you again for the next enthralling episode of Installing SharePoint 2010 beta.

 

In this episode we’ll attempt an install of SharePoint Foundation 2010 beta onto a Windows Server 2008 Standard machine to get a bit of a base line.

 

Once we have a Windows Server 2008 Standard machine we install Windows 2008 Service Pack 2 and complete all the Windows Updates. We then commence the installation of SharePoint Foundation 2010 beta.

 

image_2_22D6B5D9

 

Unfortunately, we don’t get very far before the following message appears telling us we need to install KB971831 and Microsoft Geneva Framework. The KB is easy enough to install via:

 

http://go.microsoft.com/fwlink/?LinkID=160770

 

But the Microsoft Geneva Framework proved a little more difficult. I eventually found a version here:

 

http://www.microsoft.com/downloads/details.aspx?familyid=118c3588-9070-426a-b655-6cec0a92c10b&displaylang=en – Beta 2 of Active Directory Federation Services 2.0, Windows Identity Foundation & Windows CardSpace 2.0

 

But don’t install it until you’ve ready the WHOLE blog post!

 

With those two pieces of software installed the reinstallation process if recommenced.

 

image_4_22D6B5D9

 

Everything is going well and I select the Standalone installation. The files get installed but when I run the configuration wizard I get the following:

 

image_6_22D6B5D9

 

An exception of type System.IO.FileNotFoundException was thrown. Additional exception information: Could not load file or assembly ‘Microsoft.IdentityModel, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The system cannot find the file specified.

Damm. After a bit of Googling turns out the issue may be with the version of Microsoft Geneva Framework that was installed as mentioned here. So now the current version of Microsoft Geneva Framework is uninstalled and the following new version of Microsoft Geneva Framework is installed:

 

http://download.microsoft.com/download/F/3/D/F3D66A7E-C974-4A60-B7A5-382A61EB7BC6/MicrosoftGenevaFramework.amd64.msi 

 

The configuration wizard is run again and viola,

 

image_8_50C40891

 

So where’s the light bulb moment you are probably asking? This error I got installing on this standalone Windows Server 2008 looks almost identical to the error I got when attempting an installation on SBS 2008! So now I’m off to put those two updates on my SBS 2008 box and THEN try another installation of SharePoint Foundation 2010 beta on SBS 2008. Wish me luck.

SharePoint Foundation 2010 beta on SBS 2008

It’s Buster the SharePoint crash test dummy back again with more early experiences of SharePoint 2010 beta. In our last episode you’ll remember that I tried to install SharePoint Server 2010 beta onto SBS 2008 with the results being a fiery wreck. I’m sorry to say that it is much the same story if you try and install SharePoint Foundation 2010 beta on SBS 2008.

 

When you do install SharePoint Foundation 2010 beta on SBS 2008 it at least recognizes that a previous version of SharePoint exists and gives you the option to upgrade.

 

image_2_242AED87

 

Problem is, that is the ONLY option you get to choose. After merrily clicking away and waiting for the installation to complete you get a screen displayed like so:

 

image_4_5218403F

 

So the end result is that it doesn’t install. I’m a little annoyed that I have to pick through the flaming pieces to find the location of the setup log. Why couldn’t there simply be a link here? Maybe in the full version.

 

The good thing, from I can see, is that even after this failed upgrade process http://companyweb and the SharePoint Administration site all appear to be working ok. Thank goodness. So even though the upgrade of the existing SharePoint v3 failed, the upgrade process doesn’t destroy the existing SharePoint installation unlike what happens when you attempt an install of Search Server Express on SBS 2008.

 

Now, just because it didn’t work the first time doesn’t necessarily mean it won’t work with some ‘tweaking’. Let me get back into the lab and see what I can work out. However, in the meantime I’d recommend you DON’T install SharePoint Foundation 2010 beta on SBS 2008.