Friday, October 1, 2010

Not again

I’ve been doing some testing with SharePoint Foundation 2010 on the SBS 7 preview and found that Office Web Apps installed and worked fine. However, I found that I couldn’t install Office Web Apps AND Search Server Express 2010 together on SBS 7.

 

image_2_3A6E2C5E

 

The above screen shot is where I have tried to install Search Server Express 2010 with Office Web Apps already installed on SBS 7. No go. Remove Office Web Apps and Search Server Express 2010 goes on fine. Try Office Web Apps after Search Server Express 2010 no go again!

 

Now I have successfully installed Office Web Apps and Search Server Express 2010 on a stand alone version of SharePoint 2010 Foundation so the issue has to be something to do with the way that SharePoint Foundation 2010 is installed on SBS 7.

 

This reminds me of the drama I had a while back getting Search Server 2008 to run on SBS 2008. It took a looooooong time to work that one out and I certainly hope this won’t be the case here. I have submitted the suggestion to have Search Server 2010 added to the default install of SBS 7 (as it is free anyway). Hopefully that will bring this issue to notice of the SBS team and at the very worst allow Search Server 2010 and Office Web Apps to work in tandem on SBS 7.

 

It is still early days for SBS 7 but I hope it gets resolved before the release of SBS 7 because it would be a major disappointment to see another SBS version that doesn’t easily allow the installation of Search Server Express 2010 with all the features SharePoint 2010 (read Office Web Apps) offers.

 

Back to the lab.